User Tools

Site Tools


qa:gpls_pines_evergreen_test_cases

GPLS/PINES Evergreen Test Cases

Based on the work from this page, GPLS/PINES staff have been working up test cases for versions 1.4.0.7 and 1.6.1.7 of Evergreen, with plans to add and adapt. This will begin as a dumping ground for what we have so far, and we will clean up and better organize these as we go. We're also considering adapting something like Mozilla's Litmus for this, but for now we're just creating content.

Staff Client Login

ID Test Instructions Expected Behavior
SCL-002 Login Start the staff client program and enter your username and password. Click the Login button. Staff client accepts credentials and either prompts for workstation registration (if unconfigured) or opens the main staff client window.
SCL-003 Register Workstation Set up your staff client to use the Profile Manager (see http://pines.georgialibraries.org/pines/creating-evergreen-workstation-profiles for directions). Create a new profile and register a new workstation. Workstation is registered and allows login.
SCL-004 Open New Window In the Startup and Shutdown window, click Open New Window. A new Staff Client window is opened. If not logged in first, a prompt will appear instructing you to log in first.
SCL-005 About this client… In the Startup and Shutdown window, click About this client… A window opens with version information about the Staff Client, information about Evergreen, and the text of the GNU GPL v.2.
SCL-006 Locale Switcher In the Startup and Shutdown window, select a locale in the dropdown and click the Apply Locale Button The selected locale's labels should replace the default en-US labels (where internationalization [i18n] has been developed/maintained).
SCL-007 Standalone Interface In the Startup and Shutdown window, select Standalone Interface. The standalone (offline) interface comes up.
SCL-008 Export Transactions In the Startup and Shutdown window, select Export Transactions. A Save Transaction File As dialog comes up.
SCL-009 Import Transactions In the Startup and Shutdown window, select Import Transactions. An Import Transaction File dialog comes up.

Staff Client Menus

ID Test Instructions Expected Behavior
SCM-001 File -> New Window Select New Window from the File menu to open a new window. Type Ctrl-N to do the same. New Staff Client window is opened.
SCM-002 File -> New Tab Select New Tab from the File menu to open a new tab. Type Ctrl-T to do the same. New tab is opened.
SCM-003 File -> Close Tab Open two new tabs. Select Close Tab from the File menu to close an open tab. Type Ctrl-W to do the same. The tab in focus is closed.
SCM-004 File -> Close All Tabs Open several new tabs. Select Close All Tabs from the File menu to close all tabs. Open several new tabs again and type Ctrl-Shift-W to close all tabs. All tabs are closed and remaining tab returns to start screen.
SCM-005 File -> Close Window Select Close Window from the File menu to close the staff client window. Click Open New Window in the Startup and Shutdown window, then type Ctrl-Q to close the newly opened window. Staff Client window is closed.
SCM-006 File -> Quit Program Select Quit Program from the File menu. Answer OK to the "Exit Evergreen Completely?" alert window. Evergreen Staff Client exits.
SCM-007 Edit -> Copy Buckets Select Copy Buckets from the Edit menu. The copy buckets interface comes up.
SCM-008 Edit -> Volume Buckets Select Volume Buckets from the Edit menu. The message "Just a stub, Not Yet Implemented" is shown.
SCM-009 Edit -> Record Buckets Select Record Buckets from the Edit menu. The record buckets interface comes up.
SCM-010 Edit -> User Buckets Select User Buckets from the Edit menu. The message "Just a stub, Not Yet Implemented" is shown.
SCM-011 Edit -> Replace Barcode Select Replace Barcode from the Edit menu. A pop-up box appears that allows you to enter an item barcode
SCM-012 Search -> Search for Patrons Select Search for Patrons from the Search menu. Type F4. The patron search interface comes up.
SCM-013 Search -> Search the Catalog Select Search the Catalog from the Search menu. Type F3. The advanced search interface comes up.
SCM-014 Search -> Search for a record by TCN Select Search for a record by TCN from the Search menu. Type Shift-F3. A pop-up box appears that allows you to enter a TCN or accession ID.
SCM-015 Search -> Search for a record by Record ID Select Search for a record by Record ID from the Search menu. A pop-up box appears that allows you to enter a bib record ID.
SCM-016 Search -> Search for copies by Barcode Select Search for copies by Barcode from the Search menu. Type F5. The Item Status interface comes up.
SCM-017 Search -> Search for a patron by Barcode Select Search for patron by Barcode from the Search menu. Type F1. The Retrieve Patron interface comes up.
SCM-018 Circulation -> Check Out Items Select Check Out Items from the Circulation menu. Type F1. The Retrieve Patron interface comes up.
SCM-019 Circulation -> Check In Items Select Check In Items from the Circulation menu. Type F2. The Check-In or Process Item interface comes up.
SCM-020 Circulation -> Register Patron Select Register Patron from the Circulation menu. Type Shift-F1. The patron registration interface comes up.
SCM-021 Circulation -> Retrieve Last Patron Select a patron for checkout and click the Exit button in the check out interface. Select Retrieve Last Patron from the Circulation menu. Type F8. The last patron retrieved should come up in the check out interface.
SCM-022 Circulation -> Capture Holds Select Capture Holds from the Circulation menu. Type Shift-F2. The Check-In or Process Item - Auto-Print Hold and Transit Slips interface comes up.
SCM-023 Circulation -> Pull List for Hold Requests Select Pull List for Hold Requests from the Circulation menu. The Evergreen Holds Pull List interface comes up.
SCM-024 Circulation -> Browse Holds Shelf Select Browse Holds Shelf from the Circulation menu. The Holds Shelf interface comes up.
SCM-025 Circulation -> Place Hold Select Place Hold from the Circulation menu. Type F3. The advanced search interface comes up.
SCM-026 Circulation -> Show Item Status by Barcode Select Show Item Status by Barcode from the Circulation menu. Type F5. The Item Status interface comes up.
SCM-027 Circulation -> Retrieve Patron by Barcode Select Retrieve Patron by Barcode from the Circulation menu. Type F1. The Retrieve Patron interface comes up.
SCM-028 Circulation -> Replace Barcode Select Replace Barcode from the Circulation menu. A pop-up box appears that allows you to enter an item barcode
SCM-029 Circulation -> Record In-House Use Select Record In-House Use from the Circulation menu. Type F6. The Record In-House Use interface comes up.
SCM-030 Circulation -> Re-Print Last (Requires a workstation with a configured printer). Select a patron for checkout check out an item. Then select Re-Print Last from the Circulation menu. Repeat this procedure and type F9. The previously printed receipt is re-printed.
SCM-031 Circulation -> Enter Offline Interface Select Enter Offline Interface from the Circulation Menu. The Evergreen Offline interface comes up in a tab.
SCM-032 Cataloging -> Search the Catalog Select Search the Catalog from the Cataloging menu. Type F3. The advanced search interface comes up.
SCM-033 Cataloging -> Retrieve record by TCN Select Retrieve record by TCN from the Cataloging menu. Type Shift-F3 A pop-up box appears that allows you to enter a TCN or accession ID.
SCM-034 Cataloging -> Retrieve record by Record ID Select Retreive record by Record ID from the Cataloging menu. A pop-up box appears that allows you to enter a record ID.
SCM-035 Cataloging -> Display Item Select Display Item from the Cataloging menu. Type F5. The Item Status interface comes up.
SCM-036 Cataloging -> Manage Copy Buckets Select Manage Copy Buckets from the Cataloging Menu. The copy buckets interface comes up.
SCM-037 Cataloging -> Manage Volume Buckets Select Manage Volume Buckets from the Cataloging Menu. The message "Just a stub, Not Yet Implemented" is shown.
SCM-038 Cataloging -> Manage Record Buckets Select Manage Record Buckets from the Cataloging Menu. The record buckets interface comes up.
SCM-039 Cataloging -> Create New Marc Record Select Create New Marc Record from the Cataloging Menu. The MARC Template interface comes up.
SCM-040 Cataloging -> Import Record from Z39.50 Select Import Record from Z39.50 from the Cataloging Menu. The MARC Import via Z39.50 interface comes up.
SCM-041 Cataloging -> Replace Barcode Select Replace Barcode from the Cataloging Menu. A pop-up box appears that allows you to enter an item barcode
SCM-042 Cataloging -> Retrieve Last Record Enter the advanced search interface (F3) and search for and select a bibliographic record. Type Ctrl-W to close the tab, then select Retrieve Last Record from the Cataloging menu. The last record retrieved should come up in the Record Summary interface.
SCM-043 Cataloging -> MARC Batch Import/Export Select MARC Batch Import/Export from the Cataloging Menu The Evergreen MARC File Upload interface comes up.
SCM-044 Admin -> Operator Change: New Select Operator Change: New from the Admin menu. Enter the credentials of another user. Select Operator change: [original user's name] to return to normal functions. The tab bar background turns red to indicate that the new user is now logged in. The previously logged in user's name now appears at Admin -> Operator Change: username. Selecting this returns control to the originally logged-in user.
SCM-045 Admin -> Offline Transaction Management Select Offline Transaction Management from the Admin menu. The Offline Transactions interface comes up.
SCM-046 Admin -> Download Offline Patron List Select Download Offline Patron List from the Admin menu. An alert box appears saying "Download completed."
SCM-047 Admin -> Local System Administration Select Local System Administration from the Admin menu. The Local System Administration page comes up.
SCM-048 Admin -> Server Settings Select Server Settings from the Admin menu The "Configure your ILS" interface comes up.
SCM-049 Admin -> User Permission Editor Select User Permission Editor from the Admin menu The "Retrieve Patron" dialog comes up. Entering a valid user barcode brings up the User Permission Editor.
SCM-050 Admin -> Receipt Template Editor Select Receipt Template Editor from the Admin menu The Receipt Template Editor interface comes up.
SCM-051 Admin -> Survey Wizard Select Survey Wizard from the Admin menu The Add a Survey Wizard interface comes up.
SCM-069 Help Select Help from the top menu in the Staff Client. "stub" appears.

These test the functionality of the Patron Search interface (Search -> Search For Patrons)

ID Test Instructions Expected Behavior
PSR-002 Include inactive patrons Click the checkbox that says Include inactive patrons? so that a checkmark appears. Perform a search. An Active column is added to the search results screen, indicating by Yes/No whether the patron account is marked active.
PSR-003 Limit patron search results by org unit Perform a patron name search that returns a large set of results, some of which are known to belong to your library unit. Select, in turn, the different levels of organizational units available in the "Limit results to patrons in" dropdown menu. Results are limited to the organizational unit level selected in the dropdown menu.
PSR-004 Patron search - Clear Form Populate the search fields with search data, then click the Clear Form button. Search fields are cleared for a new search.
PSR-005 Patron search - patron selection Perform a patron search. Click on the name of a patron in the results list. The search form is replaced by a summary pane of the patron account information.
PSR-006 Patron search - retrieve patron Perform a patron search. Click on the name of a patron in the results list. Click the Retrieve Patron button. The selected patron account is opened in the checkout interface in a new tab.
PSR-007 Patron search - return to search form Perform a patron search. Click on the name of a patron in the results list. Click the Search Form button. Summary pane is replaced by the search form with search terms intact. Patron search results remain.
PSR-008 Patron search - save columns Perform a patron search. Click on the column picker in the upper right of the results window. Pick an extra column to view. Click the Save Columns button. Close the tab (Ctrl-W), then re-enter the interface and perform a search. The newly selected column will be visible in the search results.
PSR-009 Patron search - copy to clipboard Perform a patron search. Click on the name of a patron in the results list. Click the Copy to Clipboard button. A pop-up window appears with hyperlinks to copy each item in the selected row to the system clipboard.
PSR-010 Patron search - Print Perform a patron search. Click Print. A printing dialog will appear and the visible patron search result set will print.
qa/gpls_pines_evergreen_test_cases.txt · Last modified: 2011/03/15 15:39 by csharp

© 2008-2017 GPLS and others. Evergreen is open source software, freely licensed under GNU GPLv2 or later.
The Evergreen Project is a member of Software Freedom Conservancy.